Qmk media keys in windows 10?


#1

Okay, I’ve never had issues with any of my boards running PS2AVR or bootmapper or TMK. But for some reason, I cannot get volume up, volume down or mute to work in QMK on windows 10. What am I doing wrong?

I’m using KC_VOLU, KC_VOLD, and KC_MUTE

Everything else on my keymaps work except for these.

Any idears?

And I’ve restarted my computer a handful of times, but that doesn’t do anything. I know in the past when windows stopped responding to media keys a restart would sometimes help. But in this case, I can connect my Alps64 board and volume controls work fine.


#2

Also tried KC_AUDIO_VOL_UP, KC_AUDIO_VOL_DOWN, and KC_AUDIO_MUTE to no avail.


#3

Got it!

EXTRAKEY_ENABLE = yes

was not declared in the make file. Added it and all works now.


#4

Thank you for posting your solution! I hate when I find a thread and it ends with the OP saying “nvm, figured it out” and they never reply again :anger::triumph:

I only regret that I have but one like to give to your post


#5

This was the LFKeyboards Hot Swap 65 board, by the way. In case anyone else comes across this issue. I might be the only person to ever have that PCB though, lol.


#6

I don’t think I’ve even heard of it :thinking:


#7

That would do it. :slight_smile:

Those keys require the “EXTRAKEY” thing to be enabled, to be able to send those keys.
Also, nice board. :slight_smile: