Atreus62 - Debugging Key Presses

Recently I soldered together an Atreus62 inside a FalbaTech High Profile bamboo case which required the pro micro to be installed upside down and flush against the pcb. After initial assembly, everything worked great! (Here’s the first layer for reference)

image

After a little while (no more than a week), I started to receive multiple key presses from anything in column 4 and ONLY column 4 (per the PCB files provided by profet23 on github https://github.com/profet23/atreus62/tree/master/pcb).

If I press 4, instead I get 12345
If I press r, instead I get (tab)qwert
If I press the f key, instead I get kl;’
If I press the v key, instead I get ZXCVB
If I press the left alt key, the QMK Keyboard Test page says I press Left Control, Left OS, Left Alt, Space, Backspace, Delete, Home, End, Left, and Right Control

My main question is… is this more likely a short between pins on the Pro Micro (my current guess)? Could it be a bad diode somewhere? What baffles me is that it worked well for a couple days before rearing its ugly head. Is it possible the pro micro went bad?

Sounds like a short to be honest :thinking: Have you tried starting with just some simple reflows?

If by reflows you mean desolder/resolder… only half way - in order to get at the backside of the controller I would have to desolder every switch because the plate and case are a single piece so I have been pushing that off unless it’s required.
If you mean something different by reflows, I’m not sure/unlikely.