BDN9 Rotary Encoder

Hello everyone,

I know close to nothing about programming. I just finished building my BDN9 and I was able to add all my macros with the help of VIA. I’m now trying to change the rotary encoder functions but I’m completely stuck with this process. Would anyone be able to help me through this process? I’m trying to make the rotary scroll up and down instead of having it change my volume.

Thank you

First off, is the encoder function enabled in via for you?

Its not, or at least I don’t see it.

So, if it’s not available in via, you’ve got 2 options.

  • an encoder enabled via firmware
  • modifying the firmware in the QMK text files.

I might be able to look at modifying a via json for you tomorrow, if you remind me.

Thank you! I’ll remind you tomorrow, appreciate it

Do you know if you have a rev1 or rev 2?

So I’ve taken what I believe to be the rev2 via json file and modified it to enable encoder support. You can view the code and download it here.

Canon has a good guide for importing a via json file; see here.

If all goes well, you should be able to import that file and a new menu will show up for modifying encoder behavior. If you can’t get what you want out of that menu, you may need to go command line.

Rev 2
Thank you! I will be trying that right now

So it worked and it did give me a menu where I can set up the CW and CWW motion of the encoder. In the “Custom Features” tab I check where it says custom 0 (which is the first CW and CWW commands). But once I go to the keyboard settings to use it, custom 0 doesn’t appear and when I go back the tab resets and nothings is configured as I had it. I’m probably doing something wrong haha

Can you post a screenshot of your configuration?

Well, I don’t think you’re doing anything wrong necessarily, but I can’t tell you why it’s behaving that way.

You just want CCW to scroll up and CW to scroll down?

I see now that it has 3 possible encoder positions, which may be messing with it.

This may be something you need to do in the command line, but it should be a simple implementation.

I’m trying to do left>scroll down, right>scroll up, press>change layer. It’s just not saving the custom into the keyboard tab. I thought that there could be a save button at the bottom that I was not seeing because of my screen but then I changed the display scale and there’s no button under it. Also, when I close via I am having to reupload the file you sent me into the design section. I’m not sure if that is normal or just not saving.

Yes, totally normal. It loads the default firmware every time, so you have to load the modified one over it.

I suspect that it’s not equipped to handle multiple encoders, which is the issue.

I would build a keymap from the command line and give that a shot. There’s a very easy guide to follow from qmk, and you can be up and running in like 15 clicks.

Thank you!

I’ll give that a try

Once you have everything setup, I’d copy the via folder in qmk_firmware/keyboards/keebio/bdn9/keymaps/ and name is tomster197. Then you can edit the keymap.c file to fit your needs. Don’t be afraid to ping me for help :grinning_face_with_smiling_eyes:

1 Like