CA66 r2 skipping keystrokes?

I’ve just build my new CA66 (r2) with the Bluetooth PCB (although I haven’t tried bluetooth yet) and I’m having annoying issues with it.

Two things.

First of all it has problem connecting with MacBook Pros, it seams happier connecting to PCs for some reason. With MacBooks it connects like 1/5 times.

When it’s connected it skips keystrokes when I’m typing fast, to verify it wasn’t just me imagining things I let another person try it, without saying anything. They connected it to their MacBook Pro and 5 min later I hear “wtf, it’s skipping keys?!”.

I’m sure this can be fixed, but it’s my frist time using this firmware so I would appreciate any suggestions :slight_smile:

It could be the bluetooth. I used the USB-to-bluetooth adapter, and it skipped sending some key-up or key-down events to the computer for my custom-build split keyboard. It operated fine for “supported” keyboards, however, like my Corsair gaming keyboard (K80 or something) and I think the Pok3r worked fine also. I worked with their support to try to figure out the source of the problem, but I think we didn’t have enough knowledge about how QMK was any different than these other keyboards.

update: Oh my bad! OP said they didn’t use bluetooth yet. Thanks @Lesbian!

ZyBeR said they hadn’t tried Bluetooth yet - it’s possible that it’s either inherent to the board or something went iffy with the QMK port.

Yeah, I’m using a usb-c cable, no bluetooth. Also it’s not QMK, it’s their default firmware (QMK isn’t available for this pcb yet).