Can't flash DZ60 after accidentally resetting it

DZ60 Rev 3 purchased in May last year
Windows 10 Professional

I really got into keyboards last year, but I have not been “in” to the hobby for quite some time so I still consider myself a newb. I remember flashing this PCB last year for the first time was also a struggle, my friend (more experienced than me) and I just tried random things until something worked. I googled and searched various threads.

Well today I was watching a TV show and wanted to dim my RGB underglow… But didn’t remember the key combo and just tried random things, then accidentally reset the PCB.

I downloaded QMK toolbox, installed drivers, uninstalled drivers… I got QMK toolbox to recognize the HID just once, I clicked “flash” and it didn’t give me any error messages, but still no keys registered. I unfortunately didn’t get a screenshot. As of now I cannot get QMK Toolbox to recognize the HID device. (Windows itself does recognize it as a keyboard though)

Would really appreciate some one-on-one help with this. I’ve tried plugging in while holding space+B and that was the one time I got Toolbox to recognize it, but after the flash failed I’ve not since been able to get it recognized. I’ve tried different cables as well

Maybe try pressing down the button on the bottom of the pcb while you plug it in? That usually puts it in the firmware update mode, although I don’t know about the dz60 specifically.

If there’s no firmware on there, space + b won’t work anymore. Look for a small label on PCB on the back marked reset. It’ll be 2 little metal pads. While plugged in and with toolbox open, short the two pads with something metal, like a paperclip. It should put the keyboard in bootloader where you can flash a fresh hex file.

That makes sense…

Are these the pads by any chance? Messing with them just disconnects/reconnects the device to windows. I see no change in QMK Toolbox.

I can also randomly get some RGB lights to turn on…

Hey. unfortunately in dztech’s infinite wisdom they didn’t put the reset points in the same place as everyone else. don’t short those parts, those are resistors. You’ll need to remove the case and find the RESET marking and short that. Also it sounds like you don’t have the DFU drivers installed. I would go on docs.qmk.fm and search for dfu and zadig. You will find instructions on how to check and install the missing DFU drivers on windows. Unfortunately windows does not ship with a working driver.

ahhh I’m back and set up again! I took the case off and reset the PCB by shorting those sockets, then using the dz60 “load” function in Toolbox didn’t work, but I had a copy of my old hex file and that worked fine.

THANK YOU!

note to self: don’t haphazardly reset the PCB again :expressionless:

1 Like

Pro Tip: Add the RESET qmk code to your keymap on a layer. Then you can enter bootloader more easily from inside the keymap.

1 Like

but that’s what led me to this predicament :sweat_smile: i had RESET mapped on a certain layer and while trying to adjust RGB (and not remembering the key combos) I accidentally reset it. I’ve learned my lesson though!

That’s weird, RESET shouldn’t flash your keyboard. You can just unplug the keyboard to boot back into firmware.