Escape to F4 keys no longer function after changing Filco Majestouch 2 Case

I recently bought a new metal case for my Filco Majestouch 2 TKL and after transferring the PCB assembly into it, I find that the cluster of keys from Escape to F4 no longer register. The case came with a new cable to convert it from a permanently attached cable to a mini USB port, so at first I thought that might be the issue, but it does the same thing with the original cable, and both in and out of the case.

So I’m thinking I must have damaged something on the PCB when I was opening up the original plastic case, since you have to sort of wedge things inside to disengage the latches that hold it together. Can someone with more knowledge than me take a look at the back of the PCB and see if anything looks amiss? Also where is the most likely source of this kind of problem?

Actually, looking at the other side of the board I now see a suspicious looking scrape over a couple of the traces. Could this be the problem? If so, how can it be fixed?

That’s probably it. You can try just melting a blob of solder on that spot and it will most likely connect the traces. If that doesn’t work, scrape the solder mask carefully with a razor until you see the copper traces. Than add a small flexible wire to connect the broken circuit

Hmm, while it’s plugged in and outside of the case, you could try shorting the esc key on the `~ key to see if you can get a response out of it.

I’ll give that a try. Should I be trying to put two separate blobs of solder to reconnect both of the traces separately? I’m still new to all of this.

two separate. If you bridge those two traces on top and bottom you’ll have more issues :slight_smile:

Good that’s what I figured. This is going to be a challenge though, since these are tiny!

Depending on where those traces go exactly, you could bridge their end points (possibly) to make it easier than working with those small traces

Before I did anything with soldering I decided to experiment by shorting the connections with tweezers, and interestingly when I short F1 through F4 they work, but they don’t work when I press the switches. And Escape does not work even if I short it.

How about like the “try 1” I have here?

That doesn’t seem to do anything, although connecting the two rightmost points does produce a ~.

I’m concerned that when I was trying to pry the plastic case open, I may have accidentally damaged something on the other side of the board, between the PCB and the plate.

I tried reflowing the solder for the problem switches and adding a little more so that it went down into the holes, working on the assumption that I might have accidentally pried the switches up enough to break the connection on the other side of the board. So far I have managed to fix F1, F3 and F4. Esc and F2 still don’t work, but I’m going to try again.

For those scratched traces if they end up needing solder flowed over them lightly scratch both on either side of the affected area to expose the copper of the trace. Then get some flux before trying to solder them. If you put a big blob of flux over the area & run a chisel tip with a decent amount of solder melted on it over the area through the flux while adding a bit more solder as you do that. The flux will ensure the solder only attaches to the exposed copper & nowhere else, making it much easier to get two small lines of solder right next to each other. For working on fixes like that & SMD components flux is your friend IME. Don’t be afraid to drown the area in flux if you have to, a blast of hot air from a heat gun or hot air station will dissipate it afterwards & you can even clean the PCB with iso alcohol after that if you want it really clean. :+1:

Well, I tried several times to reflow/resolder the Escape switch, then desoldered it and replaced it with a completely different switch, but it still doesn’t work. I don’t know a lot about PCBs, but could it be that the diode for this switch has been damaged?

1 Like

That is a possibility, in fact I just had a diode blow out on my AEK64 & had to solder an extra through hole mount diode to the spot for surface mount ones to get that switch working again. Although have you tried to repair that scratch on the traces yet? From the pic it looks like just the solder mask got knocked off & it’s on the opposite end of the board so it’s a long shot that’s the issue. But even if they aren’t broken flowing some solder over them will protect them & you never know one of the traces could be broke & pick up the esc key on it’s long run back to the controller?

I would at least try that before going to change the diode since they are on the switch side of the PCB under the plate from the looks of it. Which means you’ll have to completely de-solder all the switches to get the plate off & get at it. On the plus side from the looks of the back of the PCB the diodes could be through hole as there is a lot of things sticking out of through holes that are not switches. A through hole diode would be much easier to replace once gotten to than a surface mount one.

TBH since the new case is metal I was thinking at first you just had a short from something on the back of the PCB touching the case. Not really sure what could be going on since it is still doing it out of the case though. The only visible damage is the scratched traces so that is what I would try to fix next if you haven’t. Sorry I can’t be of more help man. :slightly_frowning_face:

I appreciate everyone’s help. I think I’m going to have to give up on this one, since I suspect that there is damage on the other side of the board that I’m unable to see or reach without desoldering the whole board, which is probably too much for me given my current skills. But the good news is that someone on MechMarket has offered to sell me a stripped down board that is identical to mine for just $50 shipped, so I will just view this as a lesson to be more careful in the future.

1 Like

Hmmm. I’d be more than happy to desolder it for you but I’m not sure how we’d go about it. Maybe I pay you to ship the board to me and you pay for me to ship it back?

Let me know if you’re interested. My desoldering equipment makes it pretty quick.

If we can’t fix it, at least you would have a plate and switches. Maybe you could build something with them?

1 Like

Thanks for the offer, but I’ll probably use it to practice desoldering, etc. and see if I can salvage the switches.