Got a new Dz60 and the FN key isn't working

I got my Dz60 today and I have on idea how to use QMK because I’ve never used it before. When I press the FN key nothing happens so I can’t access any arrow keys or the F key row. If anyone can help with this I would greatly appreciate it. Thank you.

FN will not really show up on a lot of key mappings since it it unique. It can make it difficult to test if that key is really working. For instance, using https://config.qmk.fm/#/test will not show if FN is registered/pressed.

This is the default dz60 layout - https://github.com/qmk/qmk_firmware/blob/master/keyboards/dz60/keymaps/default/keymap.c

The first blob of keys in the text file is layer 0. In the bottom right, you will see ‘MO(1)’, that is move to layer one or in your case your FN key.

It does not look like there are any arrow keys on the second layer. However is FN is working you should be able to HOLD FN and press Q to toggle RGB. That would be a good way to test if the key is working. Alternately, DELETE is mapped to BACKSPACE when FN is held. If backspace acts as delete, when holding FN, FN is working.

1 Like

I’ve just tried holding the FN key and pressing Q and nothing happened to the RBG so I’m sure the FN key isn’t working. Is there any way I can re download the default layout again as there is a chance that I messed something up when I was trying to get it to work. Sorry for being such a noob and thank you for your help.

I have tried using a different software called VIA and it has solved my issue. Thank you for your help. :slight_smile:

3 Likes

VIA is actually built on QMK, basically it’s just a much easier way to use it. Glad to hear you got your board working!

1 Like

My FN key isn’t working either on the Dz 60 how did you fix this issue.