Having trouble with AT90USB646-MU

recently I want to try out the AT90USB64 mcu, the MU package.
I got my test board and solder the necessary components (same as what I use for ATMega32u4-AU), after soldering, I use a pro micro to test the board but AVRDUDESS can’t detect the mcu (I got message “unknown signature”) :frowning_face:

I suspect the problem is one of these:

  • faulty mcu: I bought the mcu on taobao for half the price
    I have no ways to check this case
  • my soldering job is flawed
    my first time solder an mcu with MU package, took more time than AU package mcu (ATMega32u4), I guess I may have damaged the mcu.

(more likely it’s the later case)

does anyone have experience with this mcu? is there anything about this mcu that I should pay attention to? :thinking:

I thought I could use MU package to save some space, but it seems hard to solder with an iron (well… at least my skill is insufficient), I guess I will go back to AU package. I guess it’s fine since I would use this mcu for fullsize-level keyboard anyways.

Thanks for reading,


Do you have more MCUs/have you tried a second time (or even third) time? If it’s your first time working with that package you might just need some practice. I wouldnt discount fakes from taobao too…

yes, I tried the second time, I even used a magnified glass to check the soldered pads.
but it still took that much time for me… I’m worried that I could damage the mcu and I got the same result.

I think I will buy the AU package mcu and get new test board. :frowning_face: