[Help] Tofu65/DZ65 RGB V2 not responsive on boot. Please help a newbie

Hey guys!
Sorry to bother you with what is probably a beginner question, but I have this problem where my keyboard is not responsive on startup until I unplug it and plug it back. The LEDs turn on on startup, but my key presses are not registering. I did find one post about this issue on another website, but they only suggested an expert-level solution (in this case: changing some firmware code lines).

Please let me know if you need any additional information.

N.B: English is only my third language, so topics like these and are sometimes hard for me to follow.

I have had this happen in the past as well. The hard part is I don’t really know what I did to solve it. It just stopped on its own.

I would suggest simple troubleshooting techniques to begin with. Try a different cable. Try plugging into a different USB port, etc.

@Hornyciraptor did you ever find a solution? Running into the same issue with a dz65v2 rgb board I just built.

Having the same issue, sometimes works but usually doesn’t, pretty annoying…

Still haven’t found a fix. Although compiling my own firmware did seem to help from time to time. Sometimes it works on startup, sometimes it doesn’t. Seems pretty random too.

The issue sounds similar to the “ HS60/v2 keyboard unresponsive after PC wakes from sleep #5585” thread from github. It seems like flashing the latest QMK firmware might fix it, going to give it a try and see if it helps…

Maybe a workaround would be to have the usb port always powered on.
I believe that you can do this from the power settings.

1 Like

I have just tried and sadly it doesn’t work. The LEDs do stay on at all times, though.

Cool! Let me know although I have tried compiling my own firmware with the latest GitHub code available.

Didn’t help, I tried resetting the eeprom and then flashing the firmware too and it worked a couple of times by then back to the same. Very disappointing, I thought maybe it was as I was using the monitor hub but direct connection didn’t help either. What kind of system are you running? I’m on a gigabyte B550 itx board with a 5800x. Didn’t have any issues with my previous G512 Logitech board. I have soon some other reports of people with the same issues so it isn’t uncommon, I can’t believe it hasn’t been fixed… not sure whether to try and return it but I bought it ages ago…

Did you install the two static pads that come with the board? I didn’t as I didn’t see my place for them, I’d say most people don’t use them either though… board can’t be this unreliable, surely there would be more of a fuss about it?!? I see they have brought t out a v3 now though… I think I will contact the seller but I bought it ages ago and only installed it recently…

I’m not sure what you’re referring to. I don’t think I’ve received any static pads.

I am having the same problem. So does flashing help? Or any other solution?

From the kbd fans discord FAQ:

“Confused about what those little silver squares that came with your pcb are?

Those squares are grounding pads. You need to stick them onto the squares on the pcb to help prevent your pcb from shorting”

I can’t imagine this is the issue though… I thought there should be some metal contact areas where they should stick but I didn’t see any so I didn’t stick them on… maybe I should try them in case static is the problem…

I tried clearing the eeprom and reflashing and it and I don’t think it helped really but some people say it does. I think mine works about 30-40% of the time… some people say shorter usb cables help but I had the problem with a 1m (3foot) cables plugged directly into the back of the pc. I will try another cable at some stage I think though.