Help with troubleshooting an odd key malfunction

I am proud to declare than I am now the owner of a Piggy 60, but my joy turned into ash after putting my keyboard together.

My main problem is that the CAPS KEY does not function at all.

After putting the switches on the PCB and while pushing in the keycap, a light turned on and after that CAPS were locked. I pressed the key multiple times to de-active the CAPS, but the issue was not resolved until l I disconnected the keyboard alltogether. Now, after reconnecting it, the light was off, BUT the key did not work. I tried all my remaining switches (8 in total) but the problem persisted. I took the keyboard apart several times, took out the switches and put them back in place, again nothing. I checked the keyboard only on the QMK tester, and the the key does not register at all. I am at loss about what to do next. Is this an issue of the PCB? Should I be getting a new one?

And lastly, something not entirely related. Is the Piggy PCB supposed to be fixed on the plate only by the switches? I noticed no screws and when I tried to assembly the keyboard without the switches on, the PCB “fell off” in the case. Anyone with experience with Piggy that could help?

Thanks a lot!

Yes, the PCB is only attached to the plate with the switches.

Here are a few questions that may lead to more answers.

  1. Is this a brand new PCB or did you buy it used from someone else?

  2. It sounds like you are using a hotswap PCB. Is that correct?

  3. If it’s hotswap, does it register as pressed if you touch tweezers to the two metal hotswap arms for the switch on the back of the PCB?

  4. Did you try reprogramming it in VIA or VIAL to assign it to capslock?

I’m thinking it’s possible that the caps lock key is mapped to a tap dance function in QMK. Either that, or the hotswap socket is damaged internally (which is easily fixable) or externally (which would require some solder work)

That was my thought too.

@Praetor, is there any chance you’re holding rather than tapping caps lock? It seems like caps is programmed for LT(1,KC_CAPS) by default, so tapping it should activate caps but holding it will act like a function key and activate the next layer (1):

source

2 Likes

Guys, thank you so much for your suggestions.

Actually, being a total noob and an idiot I did not realise that the PCB was already mapped by the previous owner. So, apparently it needs flashing and remapping. You saved me!

2 Likes