Minivan not working

Currently built my Minivan, and worked perfectly fine for around 10 minutes before dying on me. Anybody know how I could remedy this problem?

Only thing I can think of is when the keeb was plugged in, I turned on my soldering iron to fix some mistakes I made. It’s plugged into the same outlet, so maybe that’s the problem?

Also, some method’s I’ve tried:

Changing Cable
Checking VIA (nothing pops up/no device found)
Resetting PCB

Some things that I can confirm:

Switches work
PCB works
Cable works
Computer works
Keys soldered on correctly (tested in the small window of time I had)
Nothing looks burn/fried

What pcb are you using? List

I believe I’m using the original TheVan44 pcb.

Check the MCU for a blob of solder bridging two pins that flew that way in the soldering process?

Or maybe you accidentally hit a key combo that locked you into an unmapped layer?

You said it worked for 10 minutes. Does the computer see it at all now?

When plugged in, it does make the little “device connected” sound but doesn’t do anything after that. MCU looks fine, so I’m thinking that this might be a software issue.

Minivan somehow works now. I fiddled around in QMK and something must’ve happened because it’s all good now. Now I’m scared it won’t work again in 10 minutes…


Check to make sure you don’t have reset programmed to an easy key combo


Looks like QMK wiped everything from the keeb, so currently entering back all the characters. Thanks for reminding me!

1 Like

Glad to hear it. Non vial/via QMK can get funky. Are you using the online configurator?

Nope, I’m using VIA. Is there something that I should be aware of?

My son has found that combo and came to me with “I don’t know what happened and I’m SO SORRY, but I think I may have accidentally broken your new keyboard.” I was so relieved to find out it wasn’t actually broken. lol


Nope, not with VIA. I misunderstood “entering back all the characters” as “editing/re-flashing keymap manually”. I’m glad it’s working!

1 Like