"No HID console devices connected" on QMK Toolbox

  • I have tried using three wires. I have already confirmed 2 of the three I had were able to transfer data and not just voltage.
  • reinstalling QMK Toolbox
  • Confirmed with device manager that my ports were still working
  • installed drivers both times when installing
    I am stumped and have no clue what I’m doing wrong. I have the MEGA32U4 board selected and have checked my teensy chip and its the same and am using Windows.
    Any suggestions welcome im a noob at this. Thank you. :smiling_face_with_tear:

EDIT: i got the firmware to upload i think based on qmk’s confirmation, but the keyboard still doesnt work. picture of confirmation vv (i wasnt in bootloader mode before lol)

If i can get any tips on how to troubleshoot why my keyboard isnt typing out anything at all issue that would be awesome sauce.

  • I have made sure that it is the right firmware thank youuu.
    -I have aslso went over the wires with a multimeter to test the continuity and every thing seemed fine :,(

Did you check to see if you put your PCB in bootloader mode?

Some PCBs have a button for that, or some have a key combination (like hold esc while plugging in)

I handwired the keyboard, so i dont have the PCB; however, when i tried using hold esc, hold space +B, and i also added a reset to my key map. I did not get a notification. If i try resetting the teensy would that be the same as if i had done it on a pcb? also shouldnt the toolbox recognize my device before i try to put on bootloader mode or am i mistaken? thank you so much for your assistance tho

I’d recommend going through the flashing documentation QMK has on their site. Hopefully this will be able to help. Unfortunately I don’t have much experience working with a teensy

1 Like

I believe you need to get into the HalfKay bootloader, which you do by pressing and releasing the button the Teensy (LED should stop blinking) - also, the screenshot mentioned using Teensy loader - do you have that installed / available on your path?

So you are using a pro-micro?

If yes,
Flashing Firmware | Keebio Documentation.

i do not have it installed, but ill look into it more since i knew that it existed but i was kind of confused since the chip had shown a re blink for like a second so i assumed it was already in bootloader mode but thank you

i guess? haha thank you for the resources im retrying it rn wish me luck


That’s good, right?