Stumped! Has anyone ever come across this issue? CU7 Macropad

Regarding my Capsunlocked CU7 macropad… (hence why I’m posting here… RIP CU)

So I’ve got this CU7 up and running. Flashed VIAL compatible firmware and able to assign the encoder to control volume on turn, and to mute on press. But for some weird reason, any custom keybinds I’ve set just don’t register. The only keys that are registering are a select number of media keys such as Open Calculator, Play/Pause, Vol Up + Vol Down, etc.

Also, setting the knob press as any key other than mute or the select media keys I mentioned above will not register, either.

Below is a video demonstrating what I’m talking about (please view in 1080p!):

Anyone know what gives? I wish I could contact CU themselves, but that’s not a possibility. Have tried different .hex files, baked my own in QMK… still the same results.

Thanks in advance!

1 Like

So, just recently I had a similar issue with a pro-micro board I built. The problem as I identified it was that at some point, while using Zadig to install drivers, I’d installed a driver to a device that was not in bootloader mode.

The solution was go to into device manager and uninstall all drivers associated with that device and let windows install the correct driver. Got me up and running in minutes.


Lol omg. That was it. That helped. I initially did some driver installing with zadig earlier! I must’ve gotten ahead of myself somewhere along the process. Thanks a lot!!


Glad it was an easy fix! Enjoy your board :grin:

1 Like

I waited way too long for it to come, only to spend way too much time to figure it out. I can finally enjoy it now tho thanks to your help haha. Much appreciated!

I’m sure someone else is bound to experience the same. Hope this threads ends up helping another person as well!


@hellla Where did you find the vial compatible firmware for CU7? I have been looking all over, please help. It is not listed on via website.

I used QMK Configrator(only place I could find CU7 listed) and flashed with QMK Toolbox, and now the rotary encoder has stopped functioning :stuck_out_tongue:

1 Like

Despite shutting down, Capsunlocked still has their Discord up with links to their firmwares! Here’s the CU7 firmware:

This is their VIAL compatible firmware. Let me know if you’re able to download this


Yes I was looking for their discord link all over but most of the links were expired and with their website also closed down it was real pain.

Thank you so much I was able to download this. I will flash this firmware later. Thank you. :slight_smile:

No worries! Hope everything works out :grin:

Hi All,

I might have a similar problem, but not sure. So I loaded the firmware from the CU discord and configured how I want my CU7 rotary dial to work. It should act like a mouse wheel going up and down without any modifiers. Press down on the dial, and it should affect the volume. With another modifier, it should scroll left and right. However, none of those functions work except for the volume up and down. I’m not sure what else I should do. I’m very new to the mechanical keyboard community, so I’m not sure how to make my own code and stuff like that. I appreciate any help! Thank you in advance!

Hey, so you were able to flash the CU7 with the firmware, then you configured though VIAL, yeah? Like rooski15 suggested above, you could try to reinstall your drivers

So, I did try to reinstall the drivers of the CU7; well I think I did. The problem is that nothing is labeled correctly in the device manager, and all I see is a lot of “HID-compliant devices” instead of seeing “CU7”. In your device manager, does it explicitly say “CU7”?

It’s just labeled ‘HID Keyboard Device’ for me under Keyboards in Device Manager. Try unplugging any other keyboard you might have plugged in right now and that’s not the CU7 and you can figure out which device it is that way? You can also double click the device to see details.

Yeah, I just did that and I uninstalled and reinstall, and still nothing :confused:

I might just deal with it but I want to use my CU7 for playing Cities:Skylines and using the knob for zoom and rotate would be great!


Gonna PM

@hellla Can you help me as well? I just bought a CU7 Macropad aftermarket and been trying to fix this issue u had ages ago. Recently had an issue where it wasn’t flashing on QMK so had to manually flash with msys but now the issue where any input keys i.e. alphas, numbers, etc. isnt registering except volumes and functions.

Have you tried configuring it through VIAL? Try flashing it with the VIAL firmware linked in this comment. After going back into my PMs, @pinpin890 seemed to fix their problem by flashing a different firmware from what they had. Other than that, I’m not too sure :frowning: May be a driver issue?