VIA "Searching for devices..."

I’ve been having trouble getting VIA to see any of my three compatible keyboards.

I’ve tried different cables, tried all the USB ports on my machine, even tried it on two different operating systems - so I figure I must be missing something, and probably something simple.

I’ve been able to flash plenty of boards with QMK, but I haven’t gotten VIA to recognize my NK65EE, KBD67L, or Portico. (Why, yes, I do love middle-market 65% keebs…)

Any tips for a VIA n00b?

Edit: I should note that the key-testing function in VIA does recognize inputs.

Old firmware, not VIA compatible ?
Old VIA version that does not have your keyboards information ?

1 Like

Have you put the VIA hex on those boards?,
Are you using the most recent via version?


I believe it’s the latest VIA version, 1.3.1 - all three keebs are advertised as VIA compatible.

@Manofinterests Maybe that’s what I’m missing - do I need to flash the hex file onto the boards with QMK before I can use VIA?

1 Like

The NK65s should be plug and play with VIA out of the box afaik (mine was I’m pretty sure). The rest may need you to flash the via compatible hex file before via will allow plug and play use.

You can find the compatible via hex files here:


do I need to flash the hex file onto the boards with QMK before I can use VIA?

Yes. VIA comes in two parts: app and firmware.

  • App is desktop OS specific and runs on your desktop.
  • Firmware is keyboard-specific and flashed onto the keyboard.
  • App talks to the firmware to change keyboard layout and only time it needs to do that is when the app is running.
  • Firmware on the other hand is running all the time in the keyboard when it’s plugged in.

VIA firmware is a custom QMK build so you’ll need to update even if the board already has QMK on it unless it’s VIA compatible already.


I never did manage to get plug-and-play going, but loading the .json manually works for me. (Yay!) I installed the beta firmware on my Portico, and the page has a nice short step-by-step.

I will note the current version I’m using will crash the software when clicking the “lighting” tab. From there I’ve had to restart VIA and re-load the .json, but it’s all good from there. (It also does include the default lighting controls, despite what the page says at time of writing.)