Trouble flashing QMK - No device present


#1

I’m trying to flash QMK on my DZ60, but it isn’t letting me. It’ll say DFU Device connected in QMK toolbox, but when I try to flash it, it will say no device present. I tried reinstalling the driver, and it didn’t work. It’s pretty frustrating, the keyboard isn’t really usable unless I can flash the correct layout. Any ideas on how to get it to work?


#2

Can you walk us through each step you take to flash the chip?
Also, where did you get the hex file and what are you using to flash?


#3

I got the hex file from qmkeyboard cn. I plug in the keyboard, start QMK toolbox, activate bootloader mode, then it says DFU device connected, but when I click flash, I run into the issue.


#4

In QMK Toolbox, is the corresponding micro controller and keyboard selected as well?


#5

I have the micro controller selected, but it won’t allow me to select a keyboard from qmk.fm, since I’m loading a custom firmware file.


#6

If you’re loading custom firmware, you need to select that with the Open button which will let you navigate to the file you have.


#7

Yeah, that’s what I did.


#8

Can we get a picture of the ‘terminal’ when it reads “DFU Device Connected”?


#9

You might want to manually install the drivers


#10

So, I don’t use qmk toolbox, but when I flash with dfu-programmer I have to erase existing firmware before flashing the new one, but I assume toolbox does this automagically.

This kind of error sounds like the chip not actually going into flash mode when you hit the reset button- normally I confirm this with: sudo dfu-programmer atmega32u4 get ID1

You might want to manually install the drivers

Also that- I did have to install the atmega32u4 driver in linux.


#11


#12

I’ve tried installing the drivers manually, and it didn’t work. It’s a shame I can’t get this to work.


#13

What OS are you on?


#14

I’m really confused why the keyboard from qmk.fm area is greyed out :thinking:

It is supported by qmk.config, and even putting your own hex file shouldn’t change that


#15

I’m on Windows 10. I tried using a different computer, but that didn’t work either.


#16

Try following this procedure:


#17

But the QMK flasher has been deprecated, and replaced by QMK toolbox.


#18

Try installing automatically, or download here: https://learn.adafruit.com/atmega32u4-breakout/download


#19

I already tried that.


#20

I had the same problem and after hours of trying different solutions I gave up and switched to a Linux virtual machine. I passed through the keyboard in boot loader mode and flashed the keyboard from the command line. I can provide some guidance if you want help getting one set up.