Trouble flashing QMK - No device present


#21

I might have to do that if I can’t get anything else to work, but setting up a VM would be kind of a pain, I just wish I could get it to flash with QMK toolbox.


#22

I’ve had similar problems on Windows 10.

Turned out the QMK Driver Installer installs drivers for every possible bootloader / controller by default, this confuses Windows and it doesn’t properly detect the keyboard when in bootloader mode.

Solution which worked for me was:

1.) put keyboard in bootloader mode
2.) find it in the Windows Device Manager (was under “Other” for me)
3.) Uninstall the device
4.) Download the .zip version of the QMK Driver Installer from here: https://github.com/qmk/qmk_driver_installer/releases
5.) Unzip to some temp folder
6.) Put your keyboard in bootloader mode (if it isn’t already)
7.) Run “install_connected_drivers.bat” from the folder where you unzipped the installer. This should detect your keyboard and install only the necessary driver


#23

That actually worked, thanks!


#24

Thank you very much! I had the same problem. :grin:


#25

I was trying to flash my pro micro just last night using Windows - my first time trying it using Windows. I wasn’t able to do it using qmk toolbox, I think it was because windows couldn’t see the keyboard connected or I didn’t follow the install directions properly. Thanks for sharing another idea for troubleshooting!